
Audit actions and events 
Blue Prism Enterprise 7.3.0
This data sheet lists the action and events that are written to the Blue Prism audit log. The events are 
split into the appropriate area of Blue Prism, which is also indicated by the letter prefix of the event 
number.

The information in this document is to be used with the Operational Audit Overview data sheet.

Credentials
  Audit Log Viewer Narrative Action

A001 The user [user name] created the credential 
[name].

Click New in  System > 
Security - Credentials.

A002 The user [user name] deleted the  credential  
[name].

Click Delete in  System > 
Security - Credentials.

A003 The user [user name] modified the 
credential  [name].

Click Edit in  System > 
Security - Credentials.

A004 The user [user name] modified the 
credential [name] including renaming it to 
[name]. 

Security - Credentials > Click Edit > then 
make any change, including the Name field.

Session logs 
  Audit Log Viewer Narrative Action

AR01 The user [user name] archived session 
logs: Number of records processed: [value]. 
Record date range: [date] - [date]

Click Archive in System > 
System - Archiving > Manual mode > Drag 
entry from Database Data to Archived Data.

AR02 The user [user name] deleted session logs: 
Number of records processed: [value]. 
Record date range: [date] - [date]

Click Delete in System > System - Archiving 
> Manual mode  > Select a session log in 
Database Data.

AR03 Session log restored. Click Restore in System > 
System - Archiving > Manual mode > Select 
an archived session log.

AR04 Session log cleaned. Debug sessions that 
were unable to close are now closed. 

TBC
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Business object
Code Audit Log Viewer Narrative Action

B001 The user [user name] created the business 
object [name].

Right-click an object folder in Studio and 
click Create object, or click New in the File 
menu.

B002 The user [user name] deleted the business 
object [name].

Right-click an object in Studio and click 
Delete object.

B003 The user [user name] cloned the business 
object [name].

Click Save As in Studio > Object Studio > 
File.

B004 The user [user name] modified the 
business object [name].

Click Save in Studio > Object Studio > File.

B005 The user [user name] unlocked the 
business object [name]. 

Click Unlock the business object, and start 
editing it in the Object Studio Autosave 
dialog that displays when opening a locked 
business object

B006 The user [user name] imported the 
business object: [name].

Click Process / Object in File > Import.

B007 The user [user name] exported the 
business object [name].

Click This Business Object in File > Export > 
Click Process / Object or Studio > Objects > 
Open a business object > File > Export.

B009 The user changed the attributes of the 
business object [name]. 

Actions such as retiring an active object or 
making an object available as a web service.

B010 The user [user name] refreshed the 
dependencies of the business object 
[name]. 

TBC

Calendar
  Audit Log Viewer Narrative Action

C001 The user [user name] created the calendar 
[calendar name].

Click Create a new calendar in System > 
System - Calendar.

C002 The user [user name] deleted the calendar 
[calendar name].

Click Delete the current calendar System > 
System - Calendar.

C003 The user [user name] modified the calendar 
[calendar name].

Adjust any settings and click Save  System > 
System - Calendar.

Audit Actions and Events
Business object
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Dashboards and tiles
  Audit Log Viewer Narrative Action

D001 The user [user name] created the 
dashboard  [name].

Click Create Personal/Global/Published 
Dashboard in Analytics - Dashboard.

D002 The user [user name] modified the 
dashboard  [name].

Click Edit in Analytics - Dashboard.

D003 The user [user name] deleted the 
dashboard  [name].

Click Delete Dashboard in 
Analytics - Dashboard.

D004 The user [user name] created the tile  
[name].

Click Create tile in Analytics - Tile Library.

D005 The user [user name] modified the tile  
[name].

Click Edit tile in Analytics - Tile Library.

D006 The user [user name] deleted the tile  
[name].

Click Delete tile in Analytics - Tile Library.

D007 The user [user name] set the dashboard  
[name] as their home page.

Click Set as my Home Page in 
Analytics - Dashboard.

Data Gateways
  Audit Log Viewer Narrative Action

DP01 The user [username] created the data 
gateways output configuration: [name].

Click Add a data gateways output in 
System > Data Gateways - Configuration.

DP02 The user [username]  modified the data 
gateways output configuration: [name].

Select a data gateway output >  Click Edit in 
System > Data Gateways - Configuration > 
Click Manage.

DP03 The user  [username] modified the data 
gateways settings.

Adjust any setting in System > Data 
Gateways - Settings.

DP04 The user [user name] modified the send 
interval of the published dashboard 
[dashboard name].

In System > Data Gateways > Settings, 
change the Send interval of a published 
dashboard.

DP05 The user  [user name] created the data 
gateway output configuration [name].

Click Add a data gateways output in 
System > Data Gateways > Configuration.

DP06 The user  [user name] modified the data 
gateway output configuration [name].

Edit a data gateways output in  in System > 
Data Gateways > Configuration.

DP07 The user  [username] deleted the data 
gateways output configuration: [name].

Select a data gateway output > Click Delete 
in System > Data Gateways - Configuration 
> Click Manage.

Audit Actions and Events
Dashboards and tiles
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Package 
  Audit Log Viewer Narrative Action

E001 The user     [user name] created the package: 
[package name].

Click New Package in Releases > Package.

E002 The user    [user name]  modified the 
package: [package name].

Click Modify Package in Releases > 
Package.

E003 The user   [user name] deleted the package: 
[package name].

Click Delete Package in Releases > 
Package.

E004 The user [user name] created the release  
[release name] from the package  [package 
name].

Click New Release in Releases > Package.

E005 The user imported the release [release] of 
the package [package name].

Click Import Release in Releases > Package.

E006 The user [user name] imported the release: 
[release] [1], creating a new package: 
[package name].

Click Import Release in Releases > Package.

E007 The user    [user name] imported the release: 
component [1] of the package [package 
name].

Click Import Release in Releases > Package.

Environment variables
  Audit Log Viewer Narrative Action

EV01 The user [user name] created the 
environment variable [variable name].

Click Add Variable, define its values and 
then click Apply in System > Processes - 
Environment Variables, or System > Objects 
- Environment Variables.

EV02 The user [user name] deleted the 
environment variable [variable name].

Click Remove Variable and then click Apply 
in System > Processes - Environment 
variables, or System > Objects - 
Environment variables.

EV03 The user [user name] modified the 
environment variable [variable name].

Change any variable setting value and click 
Apply in System > Processes - Environment 
Variables.

EV04 The user [user name] created the 
environment variable [variable name] using 
the command line.

Use a switch on the command line to create 
a new environment variable.

EV05 The user [user name] modified the 
environment variable [variable name] using 
the command line.

Use a switch on the command line to 
update a environment variable.

EV06 The user [user name] deleted the 
environment variable [variable name] using 
the command line.

Use the /deleteev <name> command. See 
Command line options.

Audit Actions and Events
Package
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Fonts
  Audit Log Viewer Narrative Action

F001 The user [user name] created the font [font 
name].

Click New in System > System - Fonts.

F002 The user  [user name] deleted the font [font 
name].

Click Delete in System > System - Fonts.

F003 The user [user name] modified the font 
[font name].

Click Edit in System > System - Fonts.

F004 The user [user name] modified the font 
[font name], including renaming it to [font 
name].

Click Edit and click Name in System > 
System - Fonts.

Groups
  Audit Log Viewer Narrative Action

G001 The user [user name] created the Process 
Group   [group name].

Right-click Processes, Objects, or a group 
folder and select Create group in  Studio.

G002 The user [user name] renamed the Process 
Group   [group name] to   [group name].

Right-click a group folder and click Rename 
group in  Studio.

G003 The user [user name] deleted the Process 
Group   [group name].

Right-click a group folder and click Delete 
group in  Studio.

G004 The user [user name] moved the Process 
Group   [group name].

Drag a group folder to a new location in 
Studio.

G005 The user [user name] moved the Process 
Group   [group name]. 

Drag a process group to another location in 
the Processes tree in Studio.

Environment locks
  Audit Log Viewer Narrative Action

H001 Environment lock unlocked. Right-click and click Release Locks in 
System > Workflow - Environment Locks.

Audit Actions and Events
Fonts
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Key store
  Audit Log Viewer Narrative Action

K001 The user [user name] created the 
encryption scheme [name].

Click New in System > Security - Encryption 
Schemes.

K002 The user [user name] deleted the 
encryption scheme [name].

Click Delete in  System > 
Security - Encryption Schemes.

K003 The user [user name] modified the 
encryption scheme [name].

Click Edit in  System > Security - Encryption 
Schemes.

K004 The user [user name] modified the 
encryption scheme [name] including 
renaming it to [name]. 

Click Edit > Change Name in 
Security - Encryption Schemes.

Login
Code Audit Log Viewer Narrative Action

L001 The user [user name] logged into resource  
using [authentication type] authentication.

Click Sign in using Blue Prism Credentials 
or Sign in using Active Directory on the 
Blue Prism launch screen.

L002 The user [user name] logged out of 
resource.

Click Sign out at the bottom left of the 
Interactive Client interface navigate, or:
 • Navigate to My Profile > Sign Out
 • Navigate to File > Exit

Object
  Audit Log Viewer Narrative Action

O001 The user [user name] created the business 
object [object name].

Click Create Object in Studio.

O002 The user [user name] deleted the business 
object [object name].

Click Delete Object in Studio.

O003 The user [user name] modified the business 
object [object name].

Edit an object in Object Studio.

O004 The user [user name] configured the business 
object [object name].

TBC

Audit Actions and Events
Key store

Commercial in Confidence Page 6 of 16

© 2023 Blue Prism Limited.



Process
Code Audit Log Viewer Narrative Action

P001 The user [user name] created the process 
[name].

Right-click a process folder  in Studio > 
Processes and click Create process, or click 
New in the File menu.

P002 The user [user name] deleted the process 
[name].

Right-click a process in Studio and click 
Delete process.

P003 The user [user name] cloned the process 
[name].

Click Save As in Studio > Process studio  > 
File.

P004 The user [user name] modified the process 
[name].

Click Save in Studio > Process studio  > File.

P005 The user [user name] unlocked the process 
[name]. 

Click Unlock the process, and start editing 
it in the Process Studio Autosave dialog that 
displays when opening a locked process. 

P006 The user [user name] imported the process 
component: [name].

Import Process / Object in File > Import.

P007 The user [user name] exported the process 
[name].

Click Process / Object in File > Export, or 
click This Process in Studio > Process 
studio > File > Export.

P009 The user [user name] changed the 
attributes of process [name]. 

Actions such as retiring an active process or 
making a process available as a web service.

P010 The user [user name] refreshed the 
dependencies of the process [name].

Click Publish this Process to Control Room 
in Studio > Process studio > Process.

Audit Actions and Events
Process
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Work queues
  Audit Log Viewer Narrative Action

Q001 The user [user name] created the queue 
[queue name].

Click New in System > Workflow - Work 
Queues.

Q002 The user [user name] modified the queue 
[queue name].

Adjust any settings and click Apply in 
System > Workflow - Work Queues > 
Select a work queue.

Q003 The user [user name] deleted the queue 
[queue name].

Click Delete in System > Workflow - Work 
Queues > Select a work queue.

Q004 The user [user name] manually marked an 
item with an exception from the queue 
[queue name].

Right-click a queue item  and select Mark 
Selected Case⁠(s) with Exception in Control 
Room > Queue Management.

Q005 The user [user name] manually unlocked an 
item from the queue  [queue name].

Right-click  a queue item  and select  Unlock 
Selected Case⁠(s) in Control Room > Queue 
Management.

Q006 The user [user name] deleted some 
processed items from the queue [queue 
name].

Right-click a queue item and select Delete 
Worked Case⁠(s) from Selection in Control 
Room > Queue Management.  

Q007 The user [user name] exported some data 
from the queue [queue name].

Right-click a queue item and select Export 
current view as report in Control Room > 
Queue Management.

Q008 The user [user name] forced some items to 
retry in queue [queue name].

Right-click a queue item and select Forced 
retry in Control Room > Queue 
Management. 

Q009 The user [user name] imported the queue 
[queue name]. 

TBC

Q010 The user [user name] manually deferred 
the date and time of item(s) in queue 
[queue name].

Right-click a queue item and select Change 
Deferral Date in Control Room > Queue 
Management.

Q011 Work queue [queue name] items added via 
API.

Blue Prism API.

Audit Actions and Events
Work queues
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Resource
  Audit Log Viewer Narrative Action

R001 The user [user name] created the package: 
'[package name]' 

Click New Package in the Releases pane.

R002 The user [user name] added the resource 
[resource name] to the pool [pool name].

Drag resource into pool in System > 
Resources - Pools.

R003 The user [user name] removed the 
resource [resource name] from the pool 
[pool name].

Click Remove from Pool in System > 
Resources - Pools.

R004 The user [user name] created a pool called 
[pool name].

Click New Pool in System > 
Resources - Pools.

R005 The user [user name] deleted a pool called  
[pool name].

Click Delete Pool in System > 
Resources - Pools.

System configuration
Code Audit Log Viewer Narrative Action

S001 The user [user name] modified the 
archiving settings on the resource [name].

Adjust any setting in System > 
System - Archiving.

S002 The user [user name] modified the system 
license key.

Click Install new license, or Remove in 
System > System - License.

S003 The user [user name] modified Blue Prism's 
user roles configuration.

Select or deselect any of the Permissions 
check boxes in System > Security - User 
Roles.

S004 The user [user name] modified Blue Prisms 
sign-on configuration in System Manager. 

Adjust any setting in System > 
Security - Sign-on Settings .

S005 The user [user name] modified Blue Prisms 
design control configuration.

Adjust any setting in System > 
Audit - Design Control.

S006 The user [user name] modified Blue Prisms 
sign-on settings.

Adjust any setting in System > 
Security - Sign-on Settings.

S007 The user [user name] ran the [report type] 
report.

Click Generate in System > 
System - Reporting.

S008 The user [user name] modified the MI 
Reporting configuration.

Adjust any setting in System > 
System - Reporting.

S009 The user [user name] changed the Unicode 
session logging  option .

Click Enable Unicode for session logs in 
System > System - Settings > Database.

S010 The user admin modified the encryption 
scheme [name].

Click Edit in System > Security - Encryption 
Schemes.

Audit Actions and Events
Resource
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Code Audit Log Viewer Narrative Action

S011 The user  [user name] changed the 
Resource registration mode.

Select and option from the Resource 
registration and addressing: drop down in 
System >   System - Settings > Runtime 
Resource Connectivity.

S012 The user  [user name] changed the Prevent 
Resource Registration setting.

Click Prevent registration of new Runtime 
Resources in System >  System - Settings > 
Runtime Resource Connectivity.

S013 The user  [user name] changed the Require 
Secured Resource Connection setting.

Click Require secure inbound instructional 
connections in System > System - Settings 
> Runtime Resource Connectivity.

S014 The user  admin changed the allow 
anonymous resources setting.

Click Allow anonymous public Runtime 
Resources in System >  System - Settings > 
Runtime Resource Connectivity.

S015 The user [user name] changed a system 
setting.

Adjust any setting in System >  
System - Settings.

S016 The user [user name] exported session logs 
for session [number].

Open session log and export from File menu 
in System > Audit - Process Logs.

S017 The user [user name] exported the audit 
log.

Open audit log and export from File menu in 
System > Audit - Audit Logs.

S018 The user [user name] modified group level 
access rights.

Right-click a folder in Studio > Processes, or 
Studio > Objects, and click Access Rights.

S019 The user [user name] manually released 
the archive lock.

Click Release Archive Lock in System > 
System - Archiving.

S020 The user [user name] changed the 
Scheduler settings.

Adjust any setting on this page in System > 
System - Scheduler.

S021 The user [user name] changed the session 
management enforces permissions of 
controlling user setting.

TBC

S022 The user [user name] toggled the setting 
that determines whether a personal 
Runtime Resource will start when logging 
into the client.

Click Start a personal runtime resource on 
this machine when users sign in to Blue 
Prism in System > System - Settings.

S023 The user [user name] changed the auto 
save interval value.

Click Automatically back up when editing a 
process or business object in System > 
System - Settings > System Wide Settings 
> General.

S024 The user [user name] toggled the setting 
that forces users to summarise their 
changes when saving a process or 
business object to True/False.

Click Force users to summarise their 
changes when saving a process or 
business object in System >   
System - Settings > System Wide Settings 
> General.

Audit Actions and Events
System configuration
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Code Audit Log Viewer Narrative Action

S025 The user [user name] toggled the setting 
that enables offline help to True/False.

Click Enable Offline Help in System > 
System - Settings > Offline Help.

S026 The user [user name] toggled the setting 
that enables offline help to True/False and 
updated the url to [URL].

Click Enable Offline Help and enter a Base 
URL in System > System - Settings > Offline 
Help.

S027 The user [user name]  updated the offline 
help url to [URL].

Enter a Base URL in System > 
System - Settings > Offline Help.

S028 The user toggled the setting that hides the 
Digital Exchange tab to True/False.

Click Hide the Digital Exchange tab in 
System > System - Settings > System Wide 
Settings.

S029 The user [user name] toggled the setting 
that saves Environment data to the 
database to True/False.

Click Save environment data for clients, 
runtime resources and servers to the 
database in System > System - Settings > 
System Wide Settings > Database.

S031 The user [user name] manually released 
the MI Refresh Lock.

Click Unlock in System > 
System - Reporting.

S034 The user [user name] changed the Use 
Fixed Browser Extension Port Only setting.

System > System - Settings > Click Use 
fixed browser extension port (number) 
only.
 

S035 Start creation of Blue Prism user template. Command line action. See Authentication 
Server configuration.

S036 Completed creation of Blue Prism user 
template.

Command line action. See Authentication 
Server configuration.

S037 Creation of Blue Prism user template failed. System action.

S038 Start creation of Authentication Server user 
mapping template.

Command line action. See Authentication 
Server configuration.

S039 Completed creation of Authentication 
Server user mapping template.

Command line action. See Authentication 
Server configuration.

S040 Creation of Authentication Server user 
mapping template failed.

Command line action. See Authentication 
Server configuration.

S041 Modify Blue Prism role security groups 
settings.

This action is done in Active Directory. See 
the Microsoft documentation.

S042 The user  [user name] requested an active 
directory cache refresh.

Command line action. See the Active 
Directory section in  Command line 
options.This command is available from 
Blue Prism version 7.1.2 onwards. 

S043 The user [user name] modified the prevent 
click events where JavaScript in href 
attributes may result in Content Security 
Policy violation.

Enable Prevent click events where 
JavaScript in href attributes may result in 
Content Security Policy violation, in 
System > System - Settings.

Audit Actions and Events
System configuration
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Skills
  Audit Log Viewer Narrative Action

SK01 The user [user name] modified the skill 
enabled setting.

Select or deselect checkbox for a skill in 
System > Skills - Management.

SK02 The user [user name] deleted the skill. Click a skill and Delete Skill in System > 
Skills - Management.

Schedule
  Audit Log Viewer Narrative Action

T001 The user [user name] created the schedule 
[schedule name].

Control room > Schedules - Configure 
Schedules and associated tasks > 
Right-click Schedules and click New 
Schedule.

T002 The user [user name] retired the schedule 
[schedule name].

Right-click a schedule and click Retire in 
Control room > Schedules - Configure 
Schedules and associated tasks.

T003 The user [user name] deleted the schedule 
[schedule name].

Right-click a schedule and click Delete in 
Control room > Schedules - Configure 
Schedules and associated tasks.

T004 The user [user name] modified the 
schedule [schedule name].

Click a schedule and adjust any settings in 
Control room > Schedules - Configure 
Schedules and associated tasks.

T005 The user [user name] added the task 
[schedule name] - [task name] to the 
schedule [schedule name].

Right-click a schedule and click New Task in 
Control room > Schedules - Configure 
Schedules and associated tasks.

T006 The user [user name] removed the task 
[schedule name] - [task name] from the 
schedule [schedule name].

Right-click a task and click Delete in Control 
room > Schedules - Configure Schedules 
and associated tasks.

T007 The user [user name] modified the task 
[schedule name] - [task name]on the 
schedule [schedule name].

Click a task and adjust any settings in 
Control room > Schedules - Configure 
Schedules and associated tasks.

T008 The user [user name] added [process 
name] running on  to the task [schedule 
name] - [task name]  on schedule [schedule 
name].

Click a task and drag an available process to 
an available resource Control room > 
Schedules - Configure Schedules and 
associated tasks.

T009 Process removed from a scheduled task on 
a named resource.

Click a task and delete process from 
Scheduled Sessions in Control room > 
Schedules - Configure Schedules and 
associated tasks.

T010 The user [user name] manually triggered 
the schedule [schedule name]

Right-click a schedule and click Run Now in 
Control room > Schedules - Configure 
Schedules and associated tasks.

Audit Actions and Events
Skills
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  Audit Log Viewer Narrative Action

T011 The user [user name] disabled an instance 
of schedule [schedule name]. 

Control room > Schedules - Configure 
Schedules and associated tasks.

T012 The user [user name] unretired the 
schedule [schedule name]

Control room > Schedules - Configure 
Schedules and associated tasks > 
Right-click a schedule and click Unretire.

T013 The user [user name] stopped an instance 
of schedule [schedule name]

Right-click a schedule and click Stop in 
Control room > Schedules - Configure 
Schedules and associated tasks.

Timeouts
Code Audit Log Viewer Narrative Action

TM01 The user [user name] changed timeout 
value of [timeout] from [original value] to 
[new value].

System > System > Timeouts and change 
the current value of a timeout.

TM02 The user [user name] reset all timeouts to 
default

System > System > Timeouts and click the 
Reset button for a timeout.

TM03 The user [user name] reset timeout value of 
[timeout] from [original value] to default 
[default value].

System > System > Timeouts and click 
Reset All.

User
Code Audit Log Viewer Narrative Action

U001 The user [user name] created a new user 
with name [user name].

Click Create User in System > 
Security - Users.

U002 The user [user name] deleted the user [user 
name] from the system.

Click Delete User in System > 
Security - Users.

U003 The user [user name] cloned the user [user 
name. 

TBC

U004 The user [user name] reset the password 
of the user [user name].

Enter a password in System > 
Security - Users > User > Name and 
Password tab.

U005 The user [user name] renamed the user 
[user name] to [user name].

Enter a name in System > Security - Users > 
User > Name and Password tab.

U006 The user [user name] changed the 
roles/permissions of the user [user name].

Modify any of the Roles in System > 
Security - Users >  User > Roles and 
Permissions tab.

U007 The user [user name] changed the 
password expiry of the user [user name].

Change the password expiry date in System 
> Security - Users > User > Expiry Dates 
tab.

Audit Actions and Events
Timeouts
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Code Audit Log Viewer Narrative Action

U008 The user [user name] changed the account 
expiry of the user [user name].

Change the account expiry date in System > 
Security - Users > User > Expiry Dates tab.

U009 The user [user name] unlocked the account 
of user [user name].

Click Unlock in System > Security - Users > 
User.

U011 The user [user name] changed the external 
identity of user [user name].

System > Security > Sign-on Settings.

U012 The user [user name] deleted the external 
identity of user [user name].

System > Security > Sign-on Settings.

U013 The user  [user name] mapped the user  
[user name] to an Active Directory user 
with the following SID  [ID].

This action is done in Active Directory. See 
the Microsoft documentation.

U014 The user   [user name] unmapped the  [user 
name] from an Active Directory user with 
the following SID  [ID].

This action is done in Active Directory. See 
the Microsoft documentation.

U015 The user   [user name] changed the Active 
Directory identity mapping of   [user name] 
from [value] to [value].

This action is done in Active Directory. See 
the Microsoft documentation.

U019 The user   [user name] changed   [user name] 
Authentication type to [Authentication 
type].

This action is done in Active Directory. See 
the Microsoft documentation.

U020 The user mapped    [user name] to 
Authentication Server user ID [user ID].

Command line action. See Authentication 
Server configuration

U021 The user started an Authentication Server 
mapping for [value] users.

Command line action. See Authentication 
Server configuration

U022 An Authentication Server mapping started 
by user  [user name] finished.

System action.

U023 The user mapped user [user name] to 
Authentication Server service account 
[value]. 

Command line action. See Authentication 
Server configuration.

U024 The user  [user name] changed the Blue 
Prism API permission flag of the user [user 
name] from [value] to [value].

This action is done in Active Directory. See 
the Microsoft documentation.

U025 The user [user name] restored the user 
[user name].

This action is done in Active Directory. See 
the Microsoft documentation.

U026 The user [user name] started an 
Authentication Server user 
synchronization.

Click Synchronize users with 
Authentication Server in the System > 
Security - Users menu.

U027 An Authentication Server synchronization 
started by user [user name] finished.

System action.

U028 The user [user name] changed the user 
membership of the role [role].

Click Manage role membership in System > 
Security - User Roles.

Audit Actions and Events
User
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Code Audit Log Viewer Narrative Action

U029 The user registered the Active Directory 
domain [value].

This action is done in Active Directory. See 
the Microsoft documentation.

U030 The user [user name] deregistered the 
Active Directory domain [value].

This action is done in Active Directory. See 
the Microsoft documentation.

U031 The user  [user name] updated the Active 
Directory domain [value] to [value].

This action is done in Active Directory. See 
the Microsoft documentation.

U032 The user   [user name] updated the user   
[user name] from Active Directory.

This action is done in Active Directory. See 
the Microsoft documentation.

U033 The user   [user name] started an Active 
Directory user    [user name] 
synchronization.

Click Synchronize users with Active 
Directory in System > Security - Users.

U034 An Active Directory user synchronization 
started by user     [user name] finished.

System action.

U036 The user [user name] updated the Active 
Directory domain credentials  [value] to  
[value] for domain  [value].

Click Edit in System > Security - Sign-on 
Settings > Active Directory domains.

U037 Active Directory domain could not be 
added by user [user name]. Domain [value] 
could not be verified.

Click Add in System > Security - Sign-on 
Settings > Active Directory domains. If this 
action fails, this log entry is triggered.

U038 Active Directory domain could not be 
saved by user [user name]. Domain [value] 
could not be verified.

Click  Save after making changes in System 
> Security - Sign-on Settings > Active 
Directory domains.  If this action fails, this 
log entry is triggered.

Work queue analysis
  Audit Log Viewer Narrative Action

WQ01 The user [username] created a queue 
snapshot configuration [snapshot name].

Click Add configuration in System > 
Reporting - Work Queue Snapshots.

WQ02 The user [username] edited a queue 
snapshot configuration [snapshot name].

Click Edit configuration in System > 
Reporting - Work Queue Snapshots.

WQ03 The user [username] deleted a queue 
snapshot configuration [snapshot name].

Click Delete configuration in System > 
Reporting - Work Queue Snapshots.

Audit Actions and Events
Work queue analysis
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Web connection settings
Code Audit Log Viewer Narrative Action

WS01 The user [user name] modified the default 
connection settings.

Adjust any of the Default settings on this 
page in System > Objects > Web API 
Services - Connection settings.

WS02 The user  [user name] deleted a web 
connection setting.

Click Delete in System > Objects > Web 
API Services - Connection settings.

WS03 The user  [user name] added a web 
connection setting.

Enter URI (scheme and host) and click 
Apply changes in System > Objects > Web 
API Services - Connection settings.

WS04 The user  [user name] updated a web 
connection setting.

Adjust the URI (scheme and host), 
Connection limit, Maximum Idle time 
(seconds), or Connection lease timeout 
(seconds) for an existing connection and 
Apply changes in System > Objects > Web 
API Services - Connection settings.

Audit Actions and Events
Web connection settings
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