Software download list

Blue Prism Hub

This lists all the downloads that are required to install Hub. These are all referenced later in the install guide:

Software and reference link

Related guidance

RabbitMQ 3.9.22 to 3.10.7, or 3.11.9 to 3.11.10

For more information, see Downloading and Installing RabbitMQ.

Install the Message Broker server

 

Erlang/OTP 24.x or 25.x

The version of Erlang that you require is dependent on the RabbitMQ version you intend to use. For more information, see RabbitMQ Erlang Version Requirements.

IIS 10.0

Included with Windows Server 2016, 2019 and 2022.

Install and configure the web server – Hub

 

 

 

 

ASP.NET Core Runtime 6.0.9 or 6.0.10 (Windows Hosting Bundle)

https://dotnet.microsoft.com/download/dotnet/6.0 – Select the version you require. Under ASP.NET Core Runtime, select Hosting Bundle.

.NET Desktop Runtime 6.0.9 or 6.0.10

https://dotnet.microsoft.com/download/dotnet/6.0 – Select the version you require. Under .NET Desktop Runtime, select the appropriate download.

.NET Framework 4.8

https://support.microsoft.com/en-us/topic/microsoft-net-framework-4-8-offline-installer-for-windows-9d23f658-3b97-68ab-d013-aa3c3e7495e0

This is installed by default on Windows Server 2022. You only need to install the .NET Framework if you are using Windows Server 2016 Datacenter or Windows Server 2019.

Blue Prism Hub 4.7

Download Hub from any of the following product download pages on the Blue Prism Portal:

Authentication Server SAML 2.0 extension

Download from the Digital Exchange – This is an optional installer. It is only required if you intend to use SAML 2.0 authentication.

See the installation guide on the Digital Exchange.

Blue Prism Decision

Blue Prism Decision is a license-controlled plugin in Hub. If your organization intends to use Decision, you will need to download the following in addition to the downloads listed in Blue Prism Hub.

The Decision Model Service is available using two different technologies:

  • As a Windows service
  • As a Linux container

Only one of these needs to be installed. You should download the version that most suits your organization's technical infrastructure.

Software and link

Related guidance

OpenSSL

https://www.openssl.org/source/

This is an optional download that enables you to create self-signed SSL certificates. This should only be used for POC/POV/Dev environments.

See the OpenSSL website.

To run the Decision Model Service using the container:

 

Docker Engine is the minimum that is required to run the Decision container.

https://www.docker.com/products/container-runtime

Blue Prism recommends that your production environment uses a Linux server as the host. For POC or Dev environments, a Windows server can be used running Docker Desktop.

https://www.docker.com/products/docker-desktop

For more information about installing Docker:

Blue Prism Decision Model Service container

Download from Docker Hub.

Installing Blue Prism Decision

To run the Decision Model Service as a Windows service:

 

Blue Prism Decision Model Service MSI.

Download from the Blue Prism Portal.

Installing Blue Prism Decision

To use Decision with Blue Prism:

 

Blue Prism Decision API.bprelease file

Download from the Blue Prism Portal.

Installing Blue Prism Decision

Blue Prism Interact

Blue Prism Interact is a license-controlled plugin in Hub and an additional website for end-users. If your organization intends to use Interact, you will need to download the following in addition to the downloads listed in Blue Prism Hub.

Software and reference link

Related guidance

Blue Prism Interact 4.7

Download from the Blue Prism Portal.

Install Blue Prism Interact

Blue Prism Interact Remote API.bprelease file

Download from the Blue Prism Portal.

Install and configure the Interact Web API service